Re: PWS 433au (Miata) recovery update

From: Meelis Roos (mroos@xxxxxxxx)
Date: Wed Feb 06 2019 - 03:04:21 EST


I share my experience of fresh install of and embedded SBC Alpha
(Eiger with EV6 500 MHz).

Only an ancient Debian installer worked for me. The reason appeared to
be broken IRQ numbers for Eiger.

So I used 2 disks. I first installed the ancient Debian on disk 1.
That worked.

Next, I used that to bootstrap Gentoo on second disk, with ext3 as was
supported by Debian tooling.

Then I debugged the new kernel and fixed the IRQ problem. Now I had a
recent kernel. I sent the patch https://lkml.org/lkml/2018/10/12/379 to
linux-alpha but it seems to have been ignored - PING!

Next I emerged the newest filesystem tools (e2fsutils) to support latest
ext4 features and bootstrapped next Gentoo installation from second disk to
the first disk, with ext4 and the newest kernel.

The resulting Gentoo with Eiger and patched kernel is working fine -
I have to carry the kernel patch around until gets applied upstream.

Even btrfs seems to work on alpha - I have a btrfs volume with 5x4.5G disks :)

--
Meelis Roos <mroos@xxxxxxxx>