Re: X11 system lockup with 5.11.0 kernel

From: Bob Tracy (rct@xxxxxxxx)
Date: Fri Jun 04 2021 - 01:37:15 EST


On Fri, Jun 04, 2021 at 12:18:58AM -0500, Bob Tracy wrote:
> On Thu, Jun 03, 2021 at 03:15:05PM +0200, Maciej W. Rozycki wrote:
> > I have lost track about this issue, so please fill me in as to whether
> > the offending commit causing the regression has been bisected or not.
>
> It has. Michael Cree reported the following back on April 5th:
>
> And the first bad commit is:
>
> 0fe3cf3a53b5c1205ec7d321be1185b075dff205 is the first bad commit
> commit 0fe3cf3a53b5c1205ec7d321be1185b075dff205
> Author: Christian König <christian.koenig@xxxxxxx>
> Date: Sat Oct 24 13:12:23 2020 +0200
>
> drm/radeon: switch to new allocator v2
>
> It should be able to handle all cases here.
>
> v2: fix debugfs as well
>
> Signed-off-by: Christian König <christian.koenig@xxxxxxx>
> Reviewed-by: Dave Airlie <airlied@xxxxxxxxxx>
> Reviewed-by: Madhav Chauhan <madhav.chauhan@xxxxxxx>
> Tested-by: Huang Rui <ray.huang@xxxxxxx>
> Link: https://patchwork.freedesktop.org/patch/397088/?series=83051&rev=1
>
> :040000 040000 4e643ef861b921392bc67be21a42298c91c7ff7a b36453567c3176a3cd50fa0b23886b0fd642560d M drivers

There were a few follow-up messages in this thread that left me with the
impression there *may* have been a patch submitted, although Christian
complained at the time he was having problems locating Alpha hardware to
test with.

The current (5.12.0 kernel) problem symptoms show some "improvement".
I at least got to the point that the login screen displayed, but it
had a bit of pixelation/distortion in a few areas indicative of "bad
things about to happen". Then I got the expected system lock-up,
just as I originally reported: had to hit the reset switch to recover.

--Bob