Re: why am i seeing a ~60-second network connection delay with 2.4.0test*?

From: John Kennedy (
Date: Sun Sep 03 2000 - 18:38:54 EST

On Sun, Sep 03, 2000 at 06:17:08PM -0500, Kevin Krieser wrote:
> [me]
>> I've been having a problem with the 2.4.0 series (tested most recently
>> against test8-pre1)... there is a long (seems to be almost exactly
>> ~60 seconds, but you have to be careful about racking up multiples)
>> delay trying to make outgoing connections, including pings:
> This may be a stupid suggestion, since I haven't run any 2.4 kernels yet,
> but are there any DNS problems? I know that there is a long delay when I
> telnet to my Linux system when my cable modem is disconnected. Possibly
> about a minute, though I'm 200 miles away from testing it right now.

  Should have tried to eliminate a few obvious problems like that up front
in writing for the rest of you folks, sorry.

  Booting up a 2.2.x kernel on the same box doesn't have the same
problems. Problems reaching the DNS server with the ~60 second delay
build up and multiply the problem.

  It seems like a pure 2.2.x works, 2.4.x has a delay with the rest of
the system held constant, and tried on a few machines to boot (two
different NICs so it isn't a problem with one network driver, for

  The one thing that *is* constant is my kernel config. Nobody else local
seems to be trying 2.4.x at all so I don't have a working template to
start from.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

This archive was generated by hypermail 2b29 : Thu Sep 07 2000 - 21:00:16 EST