Re: [PATCH] usb audio.

From: Erik Mouw (J.A.K.Mouw@ITS.TUDelft.NL)
Date: Fri Oct 13 2000 - 14:16:36 EST

On Fri, Oct 13, 2000 at 10:27:05AM -0700, Dunlap, Randy wrote:
> > I tried:
> >
> > setpci -s 00:07.2 latency_timer=20
> > setpci -s 00:07.2 latency_timer=40
> > setpci -s 00:07.2 latency_timer=80
> >
> > but without effect. However, the USB device doesn't have a latency
> > timer, so that probably explains.
> How about trying latency_timer=10, which will apparently
> show up as being 0 (since 10 is smaller than its
> implemented granularity).

That didn't help, but I found the problem: APM. I had GNOME battery_applet
running, and that checks /proc/apm every 2 seconds (default value).
Removing the applet from the taskbar solved the problem, and as soon as
I do "cat /proc/apm" the audio stops for about a second.

I recompiled the kernel with CONFIG_APM_ALLOW_INTS enabled, in the hope
that the USB interrupts would still come through, but that didn't solve

I'm glad I finally found the problem, but how to solve it? Is this a
bug in APM or in USB?


J.A.K. (Erik) Mouw, Information and Communication Theory Group, Department
of Electrical Engineering, Faculty of Information Technology and Systems,
Delft University of Technology, PO BOX 5031,  2600 GA Delft, The Netherlands
Phone: +31-15-2783635  Fax: +31-15-2781843  Email:
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

This archive was generated by hypermail 2b29 : Sun Oct 15 2000 - 21:00:25 EST