Re: [OT?] Coding Style

From: Georg Nikodym (georgn@somanetworks.com)
Date: Tue Jan 23 2001 - 11:14:17 EST


>>>>> "MH" == Mike Harrold <mharrold@cas.org> writes:

 MH> For exactly the reverse of that reason. Typing capital letters is
 MH> a heck of a lot more difficult that addint an underscore.

 MH> Then there is reasability.

 MH> void ThisIsMyDumbassFunctionName

 MH> if MUCH more difficult to read than

 MH> void this_is_my_clear_and_easy_function_name

I think that the distinction is moot and this argument a waste of
time. If you are anything more than a code tourist, you should have
no trouble dealing with mnemonic names. So the above can become:

/*
 * timcaefn == this is my clear and easy function name
 */
void timcaefn (void);

If you're at all concerned about RSI, your fingers will thank you.

:-) :-) :-)
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Tue Jan 23 2001 - 21:00:27 EST