Re: Aironet doesn't work

From: Francois Gouget (fgouget@free.fr)
Date: Mon Apr 30 2001 - 13:34:27 EST


On Mon, 30 Apr 2001, Jeff Garzik wrote:

> Elmer Joandi wrote:
> > the whole pcmcia does not work in 2.4.
>
> Prove it.
>
> It works for people with correct 2.4 kernel configurations.

   What is a 'correct 2.4 kernel configuration'? Or more importantly how
do I tell if mine is correct?

Here's what I have in my config file:

CONFIG_HOTPLUG=y

CONFIG_PCMCIA=y
CONFIG_CARDBUS=y
CONFIG_I82365=y

CONFIG_NET_ETHERNET=y

CONFIG_NET_RADIO=y
# CONFIG_STRIP is not set
CONFIG_WAVELAN=m
CONFIG_ARLAN=m
CONFIG_AIRONET4500=m
CONFIG_AIRONET4500_NONCS=m
# CONFIG_AIRONET4500_PNP is not set
# CONFIG_AIRONET4500_PCI is not set
# CONFIG_AIRONET4500_ISA is not set
# CONFIG_AIRONET4500_I365 is not set
CONFIG_AIRONET4500_PROC=m

CONFIG_NET_PCMCIA=y
CONFIG_PCMCIA_3C589=m
CONFIG_PCMCIA_3C574=m
CONFIG_PCMCIA_FMVJ18X=m
CONFIG_PCMCIA_PCNET=m
CONFIG_PCMCIA_NMCLAN=m
CONFIG_PCMCIA_SMC91C92=m
CONFIG_PCMCIA_XIRC2PS=m

CONFIG_NET_PCMCIA_RADIO=y
CONFIG_PCMCIA_RAYCS=m
CONFIG_PCMCIA_HERMES=m
CONFIG_PCMCIA_NETWAVE=m
CONFIG_PCMCIA_WAVELAN=m
CONFIG_AIRONET4500_CS=m

   Is there any important setting that I might have missed?

   I noticed that I was not loading the module aironet4500_proc. But
loading it does not change anything except that I now have stuff in
/proc/sys/aironet4500. But it doesn't really give me much more
information.

--
Francois Gouget         fgouget@free.fr        http://fgouget.free.fr/
   Nouvelle version : les anciens bogues ont ÚtÚ remplacÚs par de nouveaux.

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Mon Apr 30 2001 - 21:00:25 EST