On Fri, Sep 28, 2001 at 08:18:20PM +0400, firstname.lastname@example.org wrote:
> > - removed 'mask' handling from do_softirq() - it's unnecessery due to the
> > restarts. this further simplifies the code.
> Ingo, but this means that only the first softirq is handled.
> "mask" implements round-robin and this is necessary.
he's allowing to repeat the loop more than once to hide it, to do the
"mask" with repetition correctly we'd need a per-softirq counter, not
just a bitmask so it wouldn't be handy to allocate on the stack, but
it's nothing unfixable.
However I also preferred the previous behaviour, I think it was much
nicer for general purpose (non specweb99 gigabit like scenarios).
> > - '[ksoftirqd_CPU0]' is confusing on UP systems, changed it to
> > '[ksoftirqd]' instead.
> It is useless to argue about preferences, but universal naming scheme
> looks as less confusing yet. :-)
> Generally, I dislike this patch. It is utterly ugly.
I also dislike it overall but I can see why it improves performance, and
the deschedule thing makes sense for the flooding case.
I would be very confortable in only merging the deschedule part and this
is why I asked Ingo if he could measure the difference.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to email@example.com
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
This archive was generated by hypermail 2b29 : Sun Sep 30 2001 - 21:01:03 EST