Re: NFS stale mount after chroot...

From: Anders Peter Fugmann (
Date: Mon Dec 10 2001 - 07:06:56 EST

I see the same, though I have not tried to chroot.

It happens when I have run mozilla from a NFS mounted fs.

Both client and server is 2.4.16, but I have had this problem with older
kernels. NFSv3 support is compiled in both kernels.

lsof and fuser reports that no files are in use, but I'm unable to
unmount the filesystem. Btw. The filesystem is mounted ro. (and exported
ro). The exported filesystem is a reiser-fs.

I would really be greatfull if this issue was to be resolved.

Thanks in advance

Anders Fugmann

On 12/10/2001 02:57 AM, Daniel Freedman wrote:

> Hi,
> It seems like I can generate reproducible stale NFS mounts by mounting
> a partition, chroot'ing into that mount, immediately exiting the
> chroot, and then finding myself unable to unmount the NFS partition.
> I'm pretty sure I've confirmed that nothing is using the partition
> (both with fuser and lsof) and even tried to force umount the
> partition (which seems like it should definitely umount it, rather
> than returning with the same "device is busy" errors), to no avail.
> The only method which I've used that seems to be able to get rid of
> this NFS mount, is to reboot the NFS client, and clearly that's not a
> good one at all. If I'm missing something obvious here, my apologies
> in advance. Also, if there's any further information I can provide,
> I'd be happy to help. The dump of my procedure follows this message.
> Thanks again and take care,
> Daniel

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Dec 15 2001 - 21:00:17 EST