Re: IRQ Routing Problem on ALi Chipset Laptop (HP Pavilion N5425)

From: John Clemens (
Date: Mon Dec 10 2001 - 12:53:28 EST

On Mon, 10 Dec 2001, Pavel Machek wrote:

> > I've updated my bios on my Pavilion N5430 and guess what is shows on
> > the bios boot screen (if you disable the bios splash screen)... Omnibook
> > XE3. They are one in the same, at least model number wise. weird,
> > considering there are no AMD omnibooks..
> I *do* have AMD omnibook on my table.

Err.. that's weird, as if you look in HP's page, the Omnibook XE3 is
listed as Pentium3/Celeron w/ the i830MG chipset only. However, the
pictures of it show the casing to be almost identical to my N5430. But, i
don't doubt that you have one.. just an interesting observation.

> Interrupts are not comming. If I hook it on irq11 (usb), and make usb
> generate interrupts, it plays.

My apologies, i misunderstood what you were saying before.. As an
additional data point, one person who tried my origional USB hack (moving
it to IRQ 11) also reported possible problems with PCMCIA not working
anymore... this isn't my experience however. Also note that the Trident
BladeXP is also on IRQ11, not that linux should care.

Also, the N5425, and N5415 are -newer- revisions of the origional N5430
and N5470 HP Athlon based notebooks... so it's not exactly a 1:1
correlation... I'm also guessing the XE3 is not the same revision as
either of the origional ones (I have an N5430).

Also, I'm running BIOS rev GD1.08 (it shipped with GD1.03, and i tried
GD1.06 when it came out).. what is everyone else running?


John Clemens     ICQ: 7175925, IM: PianoManO8
      "I Hate Quotes" -- Samuel L. Clemens

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to More majordomo info at Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Dec 15 2001 - 21:00:18 EST