Re: 2.4.16 not booting with Athlon optimisations

From: Corrin Lakeland (
Date: Thu Dec 13 2001 - 14:39:20 EST

Hello all again,

Firstly, thanks for the quick responses!

A number of people suggested the problem was the memory write queue, via
chipset, Athlon bug. Looking into this I found I have a VIA chipset that
wasn't supported by 2.4.16 so the workaround wasn't being activated.

Last night I applied the 2.4.17-pre8 patch as well as a via-mwq.patch that
Troels sent me since the mwq appeard to add support for my chipset while
.17 didn't. These both applied fine and the machine booted with Duron
optimisation on :-) I ran an overnight stress test and it seems to be

So now all I have to do is remove the mwq patch to see if the problem was
solved just by upgrading to .17. I'll report back once I've found exactly
what fixed it.

Many thanks to all


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Dec 15 2001 - 21:00:26 EST