Re: 2.5.11 and smbfs

From: Scott A. Sibert (
Date: Fri May 03 2002 - 09:39:06 EST

Hi all.

Kernel 2.4.18 smbfs worked, 2.4.19-pre8 smbfs worked (although
fs/ufs/super.c had some missing commas), 2.5.11 smbfs didn't work. The
RedHat 7.2 had samba-2.2.1a-4 so I pulled down samba-2.2.3a-4 from the
skipjack beta and compiled it under kernel 2.5.11 and it mounts windows
shares correctly. I'm in the process of going to 2.5.13 but I'm going
to stick with the 2.2.3a-4 samba.

Thanks for all of your help.


Urban Widmark wrote:

>On Tue, 30 Apr 2002, Scott A. Sibert wrote:
>>I can mount other samba shares fine (ie. Samba-2.2.2 from OSX 10.1.4 and
>>Samba-2.2.2 from Tru64 5.1) and the directories look fine. When I mount
>>a share from a Windows 2000 server I only get the first letter of the
>>entry in the shared folder which, of course, makes no sense and
>>generates errors when just trying to get an "ls" of the share. The
>>Win2K servers are both regular server and Adv Server, both with SP2 and
>>the latest patches. The linux machine is running RedHat 7.2 with almost
>>all of the latest updates and 2.5.11 compiled.
>The server is returning unicode filenames but smbfs isn't expecting them.
>You don't say which samba version your smbmount is from, but I'm guessing
>2.2.1/2.2.2. They always negotiate unicode support without knowing if
>smbfs supports it or not, which is a bug.
>With smbfs unicode support in 2.5 this started to matter for various
>reasons. I have thought about "autodetection" and maybe that will be
>necessary anyway.
>For now, upgrading samba to 2.2.3a should fix this. Let me know if it
>To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
>the body of a message to
>More majordomo info at
>Please read the FAQ at

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Tue May 07 2002 - 22:00:19 EST