DoS ?

From: Nix N. Nix (
Date: Mon Sep 16 2002 - 20:25:54 EST

I have a situation that might be considered a DoS (just like that
special arrangement of symlinks a while back):

I have 2 computers: achilles and tux (both Linux). I mounted an SMB
shared by tux onto achilles. Then I loop-mounted an ISO found on this
share on achilles. I had to reboot tux.

Now, on achilles, trying to ls -l the mount point of the loop-mounted
ISO or the SMB mount simply hangs the ls unkillably. Not only that, but
all my cron jobs using those partitions have been hanging for days,
raising my load average considerably.

Umounting the ISO doesn't work (Device is busy), and neither does
umounting the SMB share. I tried doing a kill -9 on the pid of
"mount.smbfs" and it died, but it didn't fix the ls problem.

On tux, I shut down smbd and nmbd, and that killed the tux side of the
SMB socket from achilles. However, on achilles, netstat still says that
there's an ESTABLISHED socket to tux. I tried using one of those
kill-a-socket utils to kill it (by sending it a RST packet), but it
didn't work.

achilles is running 2.4.18 vanilla. It is an SMP box.
tux is running 2.4.19 vanilla. It is an UP box.

I would appreciate any help. Thanks.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Sep 23 2002 - 22:00:18 EST