Re: 2.5.37 won't run X?

From: Florin Iucha (
Date: Sat Sep 21 2002 - 08:41:59 EST

On Sat, Sep 21, 2002 at 12:10:41PM +0200, Helge Hafting wrote:
> X won't start on 2.5.37, but works with 2.5.36
> The screen goes black as usual, but then nothing else happens.
> ssh'ing in from another machine shows XFree86 using 50% cpu,
> i.e. one of the two cpu's in this machine.
> killing the XFre86 process is impossible, even with kill -9
> from root. sysrq SAK worked though, so I could recover
> the machine. But I had to boot a different kernel to run X.
> lspci
> 00:0f.0 VGA compatible controller: S3 Inc. ViRGE/DX or /GX (rev 01)
> 2.5.37 SMP kernel
> XFree86 Version / X Window System
> (protocol Version 11, revision 0, vendor release 6510)
> Release Date: 21 December 2001
> Distribution debian testing
> Helge Hafting

I get the same behavior on two machines here (a desktop with Duron/SIS 735
chipset/ATI 8500 video and a laptop with PIII/BX chipset/S3 Savage MX video)
so it is not hardware specific.

I am running debian testing, the laptop has XFree 4.1.0 from debian, the
desktop has XFree 4.2.0 from .

I am not runnning SMP or preempt. Preempt kernel on the laptop last
worked in 2.5.33 . When enabling preempt in 2.5.36 I get an oops, while
in 2.5.37 I get a bunch of oopses, continuously scrolling off the



"If it's not broken, let's fix it till it is."

41A9 2BDE 8E11 F1C5 87A6 03EE 34B3 E075 3B90 DFE4

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to More majordomo info at Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Sep 23 2002 - 22:00:33 EST