Re: [PATCH/RFC] New module refcounting for net_proto_family

From: Christoph Hellwig (hch@infradead.org)
Date: Fri Feb 21 2003 - 03:45:43 EST


On Thu, Feb 20, 2003 at 05:17:52PM -0800, Max Krasnyansky wrote:
> Yeah, I think 'try' is definitely be a misnomer in this case.
> How about something like this ?
>
> static inline void __module_get(struct module *mod)
> {
> #ifdef CONFIG_MODULE_DETECT_API_VIOLATION
> if (!module_refcount(mod))
> __unsafe(mod);
> #endif
> local_inc(&mod->ref[get_cpu()].count);
> put_cpu();
> }
>
> We will be able to compile the kernel with CONFIG_MODULE_DETECT_API_VIOLATION
> and easily find all modules that call __module_get() without holding a reference.

Drop the ifdef, add and add an unlikely instead?

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Sun Feb 23 2003 - 22:00:32 EST