Re: [PATCH 7/8] dm: __LOW macro fix no. 2

From: Greg KH (greg@kroah.com)
Date: Wed Feb 26 2003 - 13:14:54 EST


On Wed, Feb 26, 2003 at 05:12:49PM +0000, Joe Thornber wrote:
> Another fix for the __LOW macro.
>
> When dm_table and dm_target structures are initialized, the "limits" fields
> (struct io_restrictions) are initialized to zero (e.g. in dm_table_add_target()
> in dm-table.c). However, zero is not a useable value in these fields. The
> request queue will never let an I/O through, regardless of how small it might
> be, if max_sectors is set to zero (see generic_make_request in ll_rw_blk.c).
> This change to the __LOW() macro sets these fields correctly when they are
> first initialized. [Kevin Corry]
>
> --- diff/drivers/md/dm-table.c 2003-02-26 16:10:02.000000000 +0000
> +++ source/drivers/md/dm-table.c 2003-02-26 16:10:19.000000000 +0000
> @@ -79,7 +79,7 @@
> }
>
> #define __HIGH(l, r) if (*(l) < (r)) *(l) = (r)
> -#define __LOW(l, r) if (*(l) > (r)) *(l) = (r)
> +#define __LOW(l, r) if (*(l) == 0 || *(l) > (r)) *(l) = (r)

Any reason to not use the existing min() and max() macros instead of
these? Then:
        __HIGH(foo, bar);
can be written as:
        foo = max(foo, bar);
which is (IMHO) easier to read.

By special casing the logic in your __LOW() macro, you're only asking
for trouble in the long run :)

thanks,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Fri Feb 28 2003 - 22:00:38 EST