Re: Problem in 2.6.0-test9-mm1 with siimage+hdparm

From: Prakash K. Cheemplavam
Date: Wed Nov 05 2003 - 16:34:12 EST

Krisztian VASAS wrote:
Hello all...

I've got an Abit NF7-S v2.0 mainboard with an Athlon XP 2000+ CPU.

Yesterday I've compiled the 2.6.0-test9 kernel with -mm1 patch. My
system is on the first sata device (/dev/hde).

After reboot I've noticed an Oops after setting dma and other settings
with hdparm. Without -mm1 patch the machine works well.

After the oops I've tried to find what the problem was.

hdparm -c1 /dev/hde -> nothing was happened, switched off...
hdparm -d1 /dev/hde -> Oops...

I've got this messages:

hde: DMA timeout retry status error: status=0x58 { DriveReady
SeekComplete DataRequest }

ide2: reset phy, status=0x00000113 siimage_reset

Strange enough I have an Abit NF7-s Rev2.0 as well, but for me the driver works - somehow. I havbe latest bios 1.9 (modified with latest silicon image bios). Since siimage 1.06 drvier. I have DMA without using hdparm, but it is not as fast as in windows. With kernel 2.6 tranfer dropped very much to about 20mb/s (playing with read-aheed didn't help). But I am getting this error messages in dmesg and at boot up (that's why I commented it out in siimage.c):

hde: sata_error = 0x00000000, watchdog = 0, siimage_mmio_ide_dma_test_irq

Other than that it runs fine - forgetting that performance it bad right now. Tried various shedulers, but didn't help. With kernel 2.4.22-ac4 I had about 37mb/sec, now only 20mb/sec...


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at