Re: [PATCH] mask ADT: new mask.h file [2/22]

From: Matthew Dobson
Date: Mon Mar 29 2004 - 21:00:09 EST

On Mon, 2004-03-29 at 16:27, Paul Jackson wrote:
> Matthew wrote (of my recommendation to not use the mask type directly):
> > Is this necessary, or just convenient?
> Technically as you suspect, just convenient, except in the case of the
> mask_of_bit() macro, as you observe.
> I was adhering to the K.I.S.S. school here - just tell the user one
> recommended way of using things, suppressing my engineering urge to
> explain alternatives that had no real advantages.

That's what I figured. Just looking for a clarification.

> > I think that it wouldn't be terribly ugly to split out the 1 unsigned
> > long special cases (bitmap_and, bitmap_or, etc) with #ifdefs.
> Do you have in mind an ifdef per function, or putting
> several functions inside an ifdef? If you think it
> looks better - show us the code ;).

I was thinking of having a large ifdef'd section for the one word case.
I'll run that up and see if it does in fact look any cleaner.

> Here's my cumulative patch of changes that I have gained so far
> from your excellent feedback, and a couple I've noticed:

<diff snipped>

Looks good. I'll keep chugging along through the patches! :)


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at