Re: 2.6.5-rc3-mm1 - parse_early_options broken

From: Neil Brown
Date: Tue Mar 30 2004 - 22:37:41 EST

On Tuesday March 30, akpm@xxxxxxxx wrote:
> - Dropped the tty locking fix. As predicted, it deadlocked. I also
> reverted the patch from bk-driver-core.patch which is causing this race to
> trigger more frequently.
> - Added the rest of Ingo's recent CPU scheduler work. This is for people
> to compare with 2.6.5-rc2-mm5.

I tried 2.6.5-rc3-mm1 with a lilo.conf which had:
append="earlyprintk=vga acpi=off"

It booted all the way to trying to mount the root filesystem (which is
on /dev/sda1) and complained something about


being a bad device name. It looks like the ' ' before earlyprintk has
been swallowed.
(lilo would have made a command line of
auto BOOT_IMAGE=5 ro root=801 earlyprintk=vga acpi=off

I tried again with
append="earlyprintk=vga acpi=off root=08:01"
and it worked fine.

I hunted around and found parse_early_options and commented out

if (to != *cmdline_p)
to -= 1;

one the basis that it look suspicious, and as "to" is never (as far as
I can see) going to have the same value as *cmdline_p.

With this change, it boots nicely with the original append= line.

(The broken-out patch has a comment, but no "From:" line so I wasn't
sure who really should be told....)


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at