Re: mem=options changed in 2.6.x?

From: Randy.Dunlap
Date: Wed Mar 31 2004 - 17:02:47 EST

On Wed, 31 Mar 2004 16:28:35 -0500 (EST) Casey Allen Shobe wrote:

| I have a Compaq Proliant 5000 with 320Mb RAM.
| If I boot up either linux 2.4.22 or 2.6.4, it only identifies 12Mb of memory.
| With 2.4.22, the kernel parameters "mem=exactmap mem=640k@0M mem=319M@1M"
| worked to make the kernel identify all of the memory.
| I have tried the same with linux 2.6.4, but with the above flags the
| kernel will not boot. With "mem=320M", the system boots, but it still
| thinks it has only 12Mb RAM.
| Something I'm missing or did this change between releases?

See file: Documentation/kernel-parameters.txt

Basically, you need to change "mem=" to "memmap=" in all 3 places

"You can't do anything without having to do something else first."
-- Belefant's Law
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at