Re: hdc: lost interrupt ide-cd: cmd 0x3 timed out ...

From: Len Brown
Date: Sat May 08 2004 - 21:58:17 EST

On Fri, 2004-05-07 at 15:41, Bob Gill wrote:
> OK, great! Adding acpi=noirq to the kernel line made the lost
> interrupt problem go away.

Bob, Alex,
(or anybody else with a SIS-961 that now requires acpi=noirq),

I need some info to find out why your system recently broke.

Please open a bug here and attach the info,
or just e-mail it to me and I'll open a bug for you.

Need the complete dmesg and /proc/interrupt from the most recent ACPI
enabled kernel that worked properly -- I guess -bk6 worked okay?

Any chance you can boot with "debug" and capture the console messages
from the failure? If no, then the complete dmesg of the latest kernel
with "acpi=noirq" is the next best thing.

output from lspci -vv

output acpidmp available in /usr/sbin/, or in pmtools:


ps. would also be good to verify you're running an up-to-date BIOS.

pps. taking a wild guess, can you try backing out this patch?

# ACPI: No IRQ known ... - using IRQ 255 (Bjarni Rúnar Einarsson)

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at