Synaptics touchpad jumpy under 2.6.2+

From: Patrick Reynolds
Date: Sat May 08 2004 - 22:57:47 EST

The Synaptics touchpad on my Asus M5N laptop is jumpy (sampling ~3 times
per second or less) under Linux 2.6.2, but it works fine under 2.6.1. I
have also tried 2.6.5, and the problem persists. In all cases, the
kernels are straight from with no extra patches.

The kernel identifies my touchpad like so:

Synaptics Touchpad, model: 1
Firmware: 5.9
Sensor: 17
new absolute packet format
Touchpad has extended capability bits
-> multifinger detection
-> palm detection
input: SynPS/2 Synaptics TouchPad on isa0060/serio1

The problem shows up in both gpm (1.19.6) and XFree86 ( with the
Synaptics driver 0.13.0). It even shows up if I 'cat /dev/input/event0',
which produces 3-4 events per second under 2.6.2 and 75-80 events per
second under 2.6.1.

The touchpad problems seem to "spill over" to the keyboard. When I touch
the touchpad at all, the keyboard becomes unresponsive for a second or
two. If I don't use the touchpad, the keyboard is fine.

The keyboard and touchpad are both built in, i8042 devices.

I tried adding 'i8042.nomux' to the kernel command line. It didn't make a
difference for me.

I #define'd DEBUG in i8042.c. Here's the resulting dmesg:

Does anyone have any suggestions? Any idea what changed in 2.6.2 that
disagrees with my touchpad?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at