Re: [PATCH 2.6] Rename hardware monitoring I2C class

From: Greg KH
Date: Tue May 11 2004 - 15:49:23 EST

On Sun, May 09, 2004 at 05:48:20PM +0200, Jean Delvare wrote:
> Hi Greg, all,
> Quoting myself:
> > Mmm, I once proposed that I2C_ADAP_CLASS_SMBUS would be better renamed
> > I2C_ADAP_CLASS_SENSORS (so I2C_CLASS_SENSORS now). What about that? I
> > think it would be great to embed that change into your patch, so that
> > the name changes only once.
> >
> > BTW, if HWMON is prefered to SENSORS, this is fine with me too, I
> > have no strong preference.
> Below is a patch that does that. I finally went for HWMON. Yes, it's
> big, but it's actually nothing more than
> s/I2C_CLASS_SMBUS/I2C_CLASS_HWMON/ (thanks perl -wip :)).
> Greg, can you please apply it on top of Michael's patch?

Applied, thanks.

greg k-h
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at