Re: new laptop woes

From: Len Brown
Date: Tue May 11 2004 - 22:23:52 EST

On Tue, 2004-05-11 at 21:37, jnf wrote:

> > try booting with "nolapic"
> This worked - now seeing as it worked, and I can't find any mention of it
> in the bootparam man page [and i havent dug through the source yet], what
> exactly did i do?

Linux enables the Local APIC even on uni-processors systems so that it
can use the LOCal APIC timer. This policy causes a significant
population of laptops to freeze when booted with ACPI enabled.
Curiously, we've seen this failure go away on some laptops after a BIOS
upgrade -- so you shoul verify that you're running the latest BIOS for
your system.

Perhaps you could try the test patch here
and add a comment to the bug report on if it makes any difference or not.

> > I escaped from CVS in 1994, underwent several years of therapy, and
> > haven't used it since. I don't know what ACPI CVS is on SF, point me to
> > it and I'll be happy to delete it.
> hehe no problem, I was under the impression that was the 'official' site
> for acpi, but i found that odd seeing as nothing on the site seemed newer
> than ~12 months, and i knew that ACPI had undergone some fixes/changes
> since then.

/usr/src/MAINTAINERS lists me as the maintainer, and has this home page
for the project, which is updated periodically (tho not by me):


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at