Re: [PATCH] ide-taskfile.c fixups/cleanups part #2 [1/9]

From: Pavel Machek
Date: Fri Jul 02 2004 - 14:23:10 EST


Hi!

> > > diff -puN drivers/ide/ide-taskfile.c~ide_tf_pio_out_fixes
> > > drivers/ide/ide-taskfile.c ---
> > > linux-2.6.7-bk11/drivers/ide/ide-taskfile.c~ide_tf_pio_out_fixes 2004-06-
> > >28 21:15:54.030210376 +0200 +++
> > > linux-2.6.7-bk11-bzolnier/drivers/ide/ide-taskfile.c 2004-06-28
> > > 21:15:54.035209616 +0200 @@ -409,6 +409,10 @@ ide_startstop_t
> > > task_out_intr (ide_drive
> > > if (!OK_STAT(stat = hwif->INB(IDE_STATUS_REG), DRIVE_READY,
> > > drive->bad_wstat)) { return DRIVER(drive)->error(drive, "task_out_intr",
> > > stat);
> > > }
> > > +
> > > + if (((stat & DRQ_STAT) == 0) ^ !rq->current_nr_sectors)
> > > + return DRIVER(drive)->error(drive, __FUNCTION__, stat);
> > > +
> >
> > Looks pretty close to obfuscated c code contents... Can't you use !=
>
> wrrr...
>
> > or kill ! in second clause and use == or something?
> > Pavel
>
> is
>
> if (((stat & DRQ_STAT) != 0) ^ (rq->current_nr_sectors != 0))
>
> better?

Not much... maybe its just me but I find bitwise xor hard to read in
logical expression. Perhaps

if (!(stat & DRQ_STAT) != !rq->current_nr_sectors)
?

Pavel
--
People were complaining that M$ turns users into beta-testers...
...jr ghea gurz vagb qrirybcref, naq gurl frrz gb yvxr vg gung jnl!
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/