[RFC] Rename SECTOR_SIZE to MSDOS_SECTOR_SIZE

From: Chris Wedgwood
Date: Wed Oct 27 2004 - 01:23:55 EST


The token SECTOR_SIZE is used in multiple places that have (almost)
the same defintion everywhere.

How do people feel about rename this vague token?



===== include/linux/msdos_fs.h 1.42 vs edited =====
--- 1.42/include/linux/msdos_fs.h 2004-10-20 01:12:10 -07:00
+++ edited/include/linux/msdos_fs.h 2004-10-26 17:10:24 -07:00
@@ -6,11 +6,11 @@
*/
#include <asm/byteorder.h>

-#define SECTOR_SIZE 512 /* sector size (bytes) */
-#define SECTOR_BITS 9 /* log2(SECTOR_SIZE) */
+#define MSDOS_SECTOR_SIZE 512 /* sector size (bytes) */
+#define MSDOS_SECTOR_BITS 9 /* log2(SECTOR_SIZE) */
#define MSDOS_DPB (MSDOS_DPS) /* dir entries per block */
#define MSDOS_DPB_BITS 4 /* log2(MSDOS_DPB) */
-#define MSDOS_DPS (SECTOR_SIZE / sizeof(struct msdos_dir_entry))
+#define MSDOS_DPS (MSDOS_SECTOR_SIZE / sizeof(struct msdos_dir_entry))
#define MSDOS_DPS_BITS 4 /* log2(MSDOS_DPS) */


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/