problem booting SMP kernel !

From: Rajendra
Date: Mon Nov 08 2004 - 03:47:49 EST

Hi ,
I have been trying to boot an SMP kernel (2.4.20 redhat) on my laptop
(Dell Inspiron 5160) without any success.
It has hyper-threaded processor (Pentium IV 3.0 GHz - HT). 2.6.5 kernel is
booting fine and is able to detect the
Hyperthreading and initilize it and I can see two processors in my
/proc/cpuinfo with 2.6.5 booted up.

I searched around the internet to find out if i can get some other kernel,
or if someone has succeded in getting
SMP up on these laptops. I also tried 2.4.24 and 2.4.27 from But
all of them seem to stop at the same place.
Here is the log for 2.4.27 kernel bootup
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Booting processor 1/1 eip 2000
Not responding.
Error: only one processor found.
Warning: No sibling found for CPU 0.
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 3056.5842 MHz.
..... host bus clock speed is 0.0000 MHz.
cpu: 0, clocks: 0, slice: 0
---------------------------- HANGS here, for
ever --------------------------------------

I can send the 2.6 kernel bootup log if required !

Somewhere on the net i read that this problem is due to buggy BIOS on these
laptops, it has some problem
with APIC's. But it boots up all well with 2.6 kernel, so i think i can make
it work with 2.4. too. I have some idea
about the linux kernel and can backport the stuff from 2.6 with some help.
To be precise, if someone can
point out the cause of the problem.

I have tried the options like "acpismp=force", "acpi=off", but the problem
seems to be beyond it.

If someone has a quick workaround to make it work please let me know.

I am sending this mail for second time .... if anyone has any pointers please send it over.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at