Calibrating delay crash

From: Richard Brunelle
Date: Mon Nov 08 2004 - 12:35:44 EST

(please put me in CC when replying)

I'm having trouble booting a PentiumMMX @ 266 MHz board with 64 Mbytes of RAM. The kernel crashes while in the main.c/calibrate_delay function. It never boot, sometimes it fails and reboot, sometimes a page fault occured. I tried with the kernels 2.4.21, 2.4.26 and 2.6.7 with the same results.

I notice that if I return before the calibration loop, the system boots fine. This has been tried only for testing.

void __init calibrate_delay(void)
unsigned long ticks, loopbit;
int lps_precision = LPS_PREC;

loops_per_jiffy = (1<<12);

return; <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

printk("Calibrating delay loop... ");

I look in the archive and one post points to a memory problem, I ran memtest86 with no error found. Now I wonder what can cause this problem, is it a hardware issue/timing? What can I do to investigate more? How the calibrate_delay loop can crash the kernel?


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at