Re: Spurious interrupts when SCI shared with e100

From: Phil Oester
Date: Tue Nov 09 2004 - 11:22:49 EST

On Tue, Nov 09, 2004 at 12:42:46AM -0500, Len Brown wrote:
> On Mon, 2004-11-08 at 05:59, Udo A. Steinberg wrote:
> > My laptop has IRQ9 configured as ACPI SCI. When IRQ9 is shared between
> > ACPI and e100 an IRQ9 storm occurs when e100 is enabled, as can be
> > seen in the dmesg output below.
> Is this new with 2.6.10-rc1, or has it always been broken in an
> ACPI-enabled kernel with acpi sharing an irq with e100?
> I suspect this may be a bug in the e100 -- it may have enabled
> interrupts before it has registered a handler.

I saw similar behaviour in on a non-ACPI enabled kernel with
a dual-port e100. The nic simply would not work, spewing this error in

NETDEV WATCHDOG: eth1: transmit timed out

If I booted with an ACPI enabled kernel, the box worked again. IRQ
sharing was involved, though can't recall which IRQ eth1 tried to use.
This was on a brand new Dell Optiplex.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at