Re: isa memory address

From: Antonino Sergi
Date: Fri Nov 12 2004 - 12:32:54 EST

> > I tried but (on 2.4.2):
> > - request_region fails but, ignoring it and remapping physical address
> > to virtual, everything works fine, except for release_region, of course.
> > - request_mem_region works but what I get from communication with the
> > actual device are numbers that sometimes are surely wrong.
> As both request_region() and request_mem_region() merely reserve
> different resources in Linux structures, you can't get a different
> behavior from your device depending on which one you call, if any at all,
> unless you change code elsewhere at the same time.

You were right, there was a wrong symlink that made me compile for 2.4
with headers from 2.2; maybe some different macro substitution lead to
an actual different code. Now it works fine, with 2.6 too.

Thank you

Antonino Sergi

> Maciej

Antonino Sergi <Antonino.Sergi@xxxxxxxxxxxxx>

Radiodating Laboratory
Physics Department
University of Rome "La Sapienza"
P.le Aldo Moro 2
00185 Rome Italy
Tel +390649914206
Fax +390649914208

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at