Strange hang at init, kernel bug?

From: Mario Giammarco
Date: Sat Nov 13 2004 - 10:36:11 EST

I have this situation:

computer A: ahtlon 1600 with fibre channel hard disks connected with
mpt fusion controller.

computer B: dual pentium III with ide software raid.

in computer A hard disks have unused partitions, so I connected
computer B to fc hard disks in A with another mpt fusion controller.

I have tried with kernel 2.6.8-2.6.9 with/without kolivas, smp and
nosmp, etc.

I have tried also raid/noraid smp/nosmp

I use debian/unstable, tried with different "init" packages.

I copy using computer B the ide raid contents in fc hard disks (cp -a)
all ok without errors, I check filesystems: no errors.

Now I reboot computer B from fibre hard disk and it hangs just after

I have tried with several file systems:

- with reiser it says filesystem corrupted
- with jfs it hangs with "respawning too fast"
- with xfs it hangs with init: segmentation violation

I boot the same partition with computer A and it works...

I am desperate, what can I do?

Thanks in advance for any reply!

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at