Compiling RHEL WS Kernels

From: Paul G. Allen
Date: Sun Nov 14 2004 - 01:24:17 EST

I recently installed RHEL WS Update 3 (kernel 2.4.21-20) on my laptop.
Out of the box it does not recognize any USB devices, my Synaptics
touchpad, my PCMCIA Wireless (NetGear WAG511G) or the proper
resolution on my LCD. (NOTE: RH 9 worked perfectly OOTB on this same
machine. So far I'm not at all impressed with RHEL WS - any more than
I was with RH 7.0.)

I tried to build a new 2.4.21 kernel based upon a configuration from a
non-RH kernel (2.4.24) that worked on this machine. Not a single
module will compile correctly. I had to remove all modules and compile
them into the kernel. I2C code will not compile at all and it had to
be completely removed. After this I was able to compile a working
kernel, but it boots with errors and the NVIDIA driver will not

I've submitted a service request with Red Hat, but have not yet
received a response.

What compiler versions are known to work with this kernel?

Is this a known problem with RHEL?

My next step may be D/L the latest 2.6 stable kernel and try compiling
that (but that still leaves the question of which gcc version to use).


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at