Re: [patch] Real-Time Preemption, -RT-2.6.10-rc1-mm3-V0.7.25-1

From: K.R. Foley
Date: Sun Nov 14 2004 - 21:27:40 EST

Florian Schmidt wrote:
On Sun, 14 Nov 2004 15:15:51 +0100
Ingo Molnar <mingo@xxxxxxx> wrote:

i just build and booted into 26-3 (w/o debugging stuff) and put a
little load on the system (find /'s plus kernel compile plus
rtc_wakeup -f 8192). Got this on the console:

`IRQ 8` [14] is being piggy. need_resched=0, cpu=0

and the machine locked. will build with debugging and try to

hm, i tried and couldnt reproduce this, so i'm curious what your
debugging build yields.

not mch sadly. I tried booting into it once more and had to wait quite a
while (around 30minutes) until the lock. I got this around 10 minutes before
the lock though:

Nov 15 00:09:23 mango kernel: bug in rtc_read(): called in state S_IDLE!

Still don't think this has anything to do with the lock. This message is usually produced by reading the rtc with a program that is running at a higher priority than 'IRQ 8'. Did you chrt the 'IRQ 8' thread? Make sure the reader priority is at least 1 less than the handler.

The system locked up quitly again. no console dump. sys rq kept working (i
could sync, remount ro and reboot). Does sys rq offer diagnosis which would
be useful for you?

Possibly 't' for trace?



To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at