DMA & PDC202XX issue

From: Alan Pope
Date: Mon Nov 15 2004 - 19:01:51 EST


I have a Via based mobo with Promise PDC20265 controller with a
Seagate ST3200822A disk attached, giving me IO errors whenever I touch
the disk. I'm using the PDC202XX_OLD driver and have forced DMA on. I
have tried 2.6.8 through up to 2.6.9-ac9 and 2.6.10-rc2, all give the
same error. I can easily reproduce it with a simple "hdparm -t -T
/dev/hde" but under "normal" use such as copying files from another
disk on another channel, the same thing happens.

hde: dma_intr: status=0xff { Busy }

ide: failed opcode was: unknown
hde: DMA disabled
PDC202XX: Primary channel reset.
PDC202XX: Secondary channel reset.

(a number of times)

ide2: reset timed-out, status=0xff
end_request: I/O error, dev hde, sector 11776
Buffer I/O error on device hde, logical block 1472

(many times)

Any ideas greatfully received.
I have put some system details at if
that helps.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at