CD and 2.6 - more data fewer answers

From: Bill Davidsen
Date: Thu Dec 16 2004 - 15:07:18 EST

I have a 2.6.7-rc1-mm1 test system with both IDE CD and USB CD-R. Both work fine as I normally use them, the CD-R is my primary backup device.

With all the discussion of DMA or not DMA, I decided to try some reads... I tried readcd using /dev/hdc and the user was 60%, sys 40%, no idle. Using ATAPI:0,0,0 I saw user 60%, sys 2% idle 38%. Then using the USB device I saw user 4%, sys 9%, idle 12%, wio 75%. The USB is much faster, so this looked right, and it appeared that on data reads DMA was being used. I have no idea where all the user CPU was going.

Then I turned on -c2scan to read 2352 byte sectors without the final error correct. With /dev/hdc I saw use 42%, sys 68%. Using ATAPI:0,0,0 I saw user 47%, sys 53%. And using the USB device the c2scan ended without reading any data.

The difference between /dev/hdc and ATAPI:0,0,0 is small, although consistent. The access by SCSI number failed with the USB drive, and /dev/scd0 resulted in "readcd: Invalid argument. Cannot get SCSI I/O buffer" when tried (yes, as root as well).

I make no claim that this sheds light on the question, just a sprinkle of data to provide flavor. I'll bring in an audio CD tomorrow and see what trying to rip that does, unless someone beats me to it.

-bill davidsen (davidsen@xxxxxxx)
"The secret to procrastination is to put things off until the
last possible moment - but no longer" -me
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at