Re: Lockup with 2.6.9-ac15 related to netconsole

From: Mark Broadbent
Date: Fri Dec 17 2004 - 04:14:52 EST

Matt Mackall said:
> On Thu, Dec 16, 2004 at 04:20:02PM -0000, Mark Broadbent wrote:
>> Hi,
>> I'm having problem using ethereal/tcpdump in conjunction with the
>> netconsole (built as a module). If the netconsole is loaded and I try
>> to launch tcpdump on the same interface as the netconsole is
>> transmitting I get a hard lock-up. The following commands can
>> consistently do this: # tcpdump -i eth0
>> eth0: Promiscuous Mode Entered
>> <... normal output ...>
>> ^C
>> # modprobe netconsole
>> # tcpdump -i eth0
>> eth0: Promiscuous Mode Entered
>> <4>NMI Watchdog detected LOCKUP
> Joy. Can you try it on your other interface to see if it's
> driver-specific?

Tried using eth1 which is using the r8169 but it doesn't support polling.
I also tried with 2.6.10-rc3-bk10 but it still doesn't support polling.
Also it still locks up using eth0 (the tulip driver) with 2.6.10-rc3-bk10.

Mark Broadbent <markb@xxxxxxxxxxxxxx>

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at