From: Sasa Ostrouska
Date: Tue Dec 21 2004 - 10:23:34 EST

Dear Sirs,

I have a little problem or maybe big one. I try to
put to work the kernel-2.6.9 on my machine. I have a slackware
current install and the following hardware.

AMD Athlon
HPT 370 RAID controller
and 2 HDD in RAID1

So when I start the kernel-ataraid-2.4.27 everything works OK.
When I start the installed kernel-2.6.9 I get the following error

VFS: Cannot openroot device "7203" or unknown-block(114,3)
Please append a correct "root=" option
Kernel panic: VFS: Unable to mount root fs on unknown-block(114,3)

On my lilo.conf is root=/dev/ataraid/d0p3
as this is the / partition.

I tried to put the root=/dev/hde at the lilo prompt but no
I tried many many forums but nobody was able to answer me. So
my last sollution is you and I will very very apreciate it if
you can give me some hints how to do it. I append you also a
dmesg from the 2.4.27 kernel.

Many thanks in advance for your help !!!

Best Regards
Sasa Ostrouska

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at