Re: XFS: inode with st_mode == 0

From: Jakob Oestergaard
Date: Wed Dec 22 2004 - 03:44:44 EST

On Tue, Dec 21, 2004 at 07:43:04PM +0100, Jan Kasprzak wrote:
> :
> : No, the problem I've fixed was related to XFS getting the inode version
> : number wrong - or at least different than NFSD expects.
> :
> We have applied these two patches to 2.6.10-rc2, but this
> does not help. A few minutes ago I've got the "?----------" file
> again from my test script. This time it took >4 hours (it was
> about an hour or so without this patch).

I run the patch on 2.6.9 - it solved the problem in the common case.
Before the patch, I was unable to complete a "cvs checkout" of a
moderately large tree - would end up with undeletable directories and
lots of other weird things... After the patch, I can run cvs checkout.

However, we still see the problem - so the patch does not solve this
completely, as you have observed as well.

Our most common situation is that a new file gets created as a symlink
pointing to itself, instead of as a regular file.

It also happens regularly, that a command (be it cvs, etags, ld or
something else) reports EINVAL when attempting to create/write a file.

So, status on my side is; things still suck, but they suck less than on
vanilla 2.6.9


/ jakob

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at