Re: cannot eject drive using pktcdvd

From: Peter Osterlund
Date: Wed Dec 22 2004 - 18:24:30 EST

Vince <fuzzy77@xxxxxxx> writes:

> I see the following bug since I've enabled packet writing for my dvd
> drive (using the udftools package):
> - eject won't open the tray unless I'm root
> - whether I'm root or not, I get the following error when running eject:
> "eject: unable to eject, last error: Invalid argument"
> and in the system logs:
> "program eject is using a deprecated SCSI ioctl, please convert it to SG_IO"
> The command: pktsetup dvd /dev/cdrom ; eject
> should allow anyone with a cd/dvd writer to reproduce this bug.
> Disabling packet writing ("pktsetup -d dvd") solves the problem and
> everything works fine (no strange message in the logs).

I can't reproduce any of these problems on my laptop. I run FC3 and
kernel 2.6.10-rc3-bk6. I tried both with a USB CDRW drive and an IDE
DVD+RW drive.

More info is needed. What distribution? What kernel? And please
provide strace logs from eject when it fails.

Peter Osterlund - petero2@xxxxxxxxx
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at