[patch 04/11] list_for_each_entry: arch-um-drivers-chan_kern.c

From: domen
Date: Tue Jan 11 2005 - 19:13:30 EST








Make code more readable with list_for_each_reverse.

Signed-off-by: Domen Puncer <domen@xxxxxxxxxxxx>
Signed-off-by: Maximilian Attems <janitor@xxxxxxxxxxxxxx>
Acked-by: Jeff Dike <jdike@xxxxxxxxxxx>
Signed-off-by: Domen Puncer <domen@xxxxxxxxxxxx>
---


kj-domen/arch/um/drivers/chan_kern.c | 4 +---
1 files changed, 1 insertion(+), 3 deletions(-)

diff -puN arch/um/drivers/chan_kern.c~list-for-each-entry-drivers_chan_kern arch/um/drivers/chan_kern.c
--- kj/arch/um/drivers/chan_kern.c~list-for-each-entry-drivers_chan_kern 2005-01-10 17:59:42.000000000 +0100
+++ kj-domen/arch/um/drivers/chan_kern.c 2005-01-10 17:59:42.000000000 +0100
@@ -218,7 +218,6 @@ void enable_chan(struct list_head *chans

void close_chan(struct list_head *chans)
{
- struct list_head *ele;
struct chan *chan;

/* Close in reverse order as open in case more than one of them
@@ -226,8 +225,7 @@ void close_chan(struct list_head *chans)
* state. Then, the first one opened will have the original state,
* so it must be the last closed.
*/
- for(ele = chans->prev; ele != chans; ele = ele->prev){
- chan = list_entry(ele, struct chan, list);
+ list_for_each_entry_reverse(chan, chans, list) {
if(!chan->opened) continue;
if(chan->ops->close != NULL)
(*chan->ops->close)(chan->fd, chan->data);
_
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/