[PATCH 0/12] random pt3: More core and accounting cleanups

From: Matt Mackall
Date: Wed Jan 19 2005 - 03:55:35 EST


This is a third series of various cleanups for drivers/char/random.c.
It applies on top of the previous 10.

These bits greatly simplify the setup:
1 More meaningful pool names
2 Static allocation of pools
3 Static sysctl bits

These bits make the accounting safer and the code easier to follow:
4 Catastrophic reseed checks
5 Entropy reservation accounting
6 Reservation flag in pool struct
7 Reseed pointer in pool struct
8 Break up extract_user

These bits clean up the hashing functions:
9 Remove dead MD5 copy
10 Simplify hash folding
11 Clean up hash buffering

This bit drops a bunch of code and reduces lock hold times:
12 Remove entropy batching

The next series focuses on moving and sharing code more appropriately.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/