Re: DVD burning still have problems

From: Alessandro Suardi
Date: Sun Jan 23 2005 - 11:29:28 EST

On Sun, 23 Jan 2005 17:06:54 +0100, Kasper Sandberg <lkml@xxxxxxxxxxx> wrote:
> hello, i followed the last thread, "unable to burn DVD", and there was a
> patch, which was said to work, but it does not.. (i am running
> 2.6.11-rc1-bk9)..
> the problem started around 2.6.9 (or something like it), when i was only
> able to burn 1 dvd, then i had to restart before i could burn another
> (or every second dvd i burn would fail), the error i get is input/output
> error.. my burner is working perfect, since it works on windows, and on
> 2.6.9-rcSomething.
> it is not a specific place in the burning process it fails, sometimes at
> 10%, and sometimes at 97%
> burning normal cd's works perfectly
> now on 2.6.10 and 2.6.11-later i cant burn dvd's at all, every time i
> try to burn one, it fails, i have tried different speeds and media, same
> thing, i got a Liteon sohw1213S dvd duallayer burner, allthough im not
> using duallayer media.
> here is a log from a burning i just tried:
> /dev/hda: engaging DVD-R DAO upon user request...
> /dev/hda: reserving 2149200 blocks
> /dev/hda: "Current Write Speed" is 4.1x1385KBps.
> 0.02% done, estimate finish Tue Jan 25 13:20:53 2005
> 0.05% done, estimate finish Mon Jan 24 15:13:15 2005
> <snip>
> 83.66% done, estimate finish Sun Jan 23 16:50:47 2005
> 83.68% done, estimate finish Sun Jan 23 16:50:47 2005
> 83.71% done, estimate finish Sun Jan 23 16:50:46 2005
> :-[ WRITE@LBA=1b7460h failed with SK=3h/ASC=0Ch/ACQ=00h]: Input/output
> error
> :-( write failed: Input/output error
> /dev/hda: flushing cache
> this is simply what happens :(
> i have tried with and without pktcdvd loaded, same result, i hope
> someone can help me

FWIW, I happen to experience the same with the latest
FC3 kernel on my Samsung TS-H552 burner; that is,

1. CD burning works 100% of the time
2. DVD burning may fail with EIO (nothing in kernel logs)
3. retrying burning usually works

Yes, I resorted to only use DVD+RW media now since the
ratio of coasters has made +R more expensive than +RW :(

Last night I had to insist quite a lot with my burner's eject
button before it decided to open and let the disc out (this
particular session after failing once at 61% with EIO would
reliably fail at the initial write). After reloading the tray
with the same disc, I successfully burned it.

NB - this happens with Memorex and Verbatim media,
not with el-cheapo discs.

I'm available for eventually testing of the 2.6.11-xx kernels
from (another side-effect of moving from RH9
plus kernels to FC3 and its own kernel is that I
no longer have a dead machine after the updatedb run,
which would happen about twice a month on my 256MB
RAM k7-800).


"And every dream, every, is just a dream after all"

(Heather Nova, "Paper Cup")
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at