Re: [PATCH 2/5] ppc RT: ppc_cpu_khz.patch

From: Mikael Pettersson
Date: Tue Mar 08 2005 - 05:02:56 EST


Frank Rowand writes:
> Source: MontaVista Software, Inc.
> Signed-off-by: Frank Rowand <frowand@xxxxxxxxxx>
>
> Index: linux-2.6.10/arch/ppc/platforms/prpmc800.c
> ===================================================================
> --- linux-2.6.10.orig/arch/ppc/platforms/prpmc800.c
> +++ linux-2.6.10/arch/ppc/platforms/prpmc800.c
> @@ -331,6 +331,7 @@ static void __init prpmc800_calibrate_de
> tb_ticks_per_second = 100000000 / 4;
> tb_ticks_per_jiffy = tb_ticks_per_second / HZ;
> tb_to_us = mulhwu_scale_factor(tb_ticks_per_second, 1000000);
> + cpu_khz = tb_ticks_per_second / 1000;
> return;
> }
>
> @@ -371,6 +372,7 @@ static void __init prpmc800_calibrate_de
> tb_ticks_per_second = (tbl_end - tbl_start) * 2;
> tb_ticks_per_jiffy = tb_ticks_per_second / HZ;
> tb_to_us = mulhwu_scale_factor(tb_ticks_per_second, 1000000);
> + cpu_khz = tb_ticks_per_second / 1000;

etc

While I really like the idea of adding a cpu_khz platform variable
to ppc32 (my ppc32 perfctr driver has to do horrible things trying
to retrieve the TB and core frequencies), it looks to me as if your
cpu_khz really is the TB frequency not the core frequency. If so,
then please rename it to tb_khz to avoid confusion.

/Mikael
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/