RE: [ANNOUNCE][PATCH 2.6.11 2/3] megaraid_sas: Announcing new mod ule for LSI Logic's SAS based MegaRAID controllers

From: Bagalkote, Sreenivas
Date: Wed Mar 09 2005 - 12:49:09 EST

>> >
>> >> . And since this is compile time
>> >> system-wide property, I kept it as driver global.
>> >
>> >that step I don't understand... why is it a global
>*VARIABLE* if it's
>> >compile time system-wide property...
>> >
>> I see your point! Are you saying I should use
>> instead of the shortcut if(is_dma64)?
>well you can use a preprocessor define of something to make it slightly
>more readable (eg shortcut) if you want, but that's what I mean yeah..
>gcc will optimize the entire unused code away this way, including the
>actual conditional jump, so for performance and bloat-ness
>point of view
>it's nice.... and of course generic design beauty ;)

Great. Thanks! I will change it. If I understand you correctly, I should
#define IS_DMA64 (sizeof(dma_addr_t)==8).

Is this better than declaring is_dma64 global variable const? (Excuse the
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at