Re: [patch] Real-Time Preemption, -RT-2.6.12-rc1-V0.7.41-01

From: Ingo Molnar
Date: Tue Mar 22 2005 - 03:52:39 EST



* Paul E. McKenney <paulmck@xxxxxxxxxx> wrote:

> return;
> }
> rdp->donelist = NULL;
> - rdp->donetail = &rdp->waitlist;
> + rdp->donetail = &rdp->donelist;
> put_cpu_var(rcu_data);
> while (list) {
> next = list->next;

seems like the RCU code should use list.h primitives, to avoid bugs like
this and to make the code more readable.

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/