Re: Use of C99 int types

From: Dag Arne Osvik
Date: Sun Apr 03 2005 - 18:04:25 EST


Al Viro wrote:

On Sun, Apr 03, 2005 at 02:30:11PM +0200, Dag Arne Osvik wrote:


Yes, but wouldn't it be much better to avoid code like the following, which may also be wrong (in terms of speed)?

#ifdef CONFIG_64BIT // or maybe CONFIG_X86_64?
#define fast_u32 u64
#else
#define fast_u32 u32
#endif



... and with such name 99% will assume (at least at the first reading)
that it _is_ 32bits. We have more than enough portability bugs as it
is, no need to invite more by bad names.



Agreed. The way I see it there are two reasonable options. One is to just use u32, which is always correct but sacrifices speed (at least with the current gcc). The other is to introduce C99 types, which Linus doesn't seem to object to when they are kept away from interfaces (http://infocenter.guardiandigital.com/archive/linux-kernel/2004/Dec/0117.html).

--
Dag Arne

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/