Re: [PATCH 2/4] rt_mutex: add new plist implementation

From: Oleg Nesterov
Date: Mon May 09 2005 - 11:14:32 EST


Daniel Walker wrote:
>
> On Mon, 9 May 2005, Oleg Nesterov wrote:
>
> > This patch adds new plist implementation, see
> > http://marc.theaimsgroup.com/?l=linux-kernel&m=111547290706136
> >
> > Changes:
> >
> > added plist_next_entry() helper (was plist_entry)
> >
> > added plist_unhashed() helper, see PATCH 4/4
> >
>
> Naw , stick with Inaky's API ..

This patch breaks Inaky's API anyway, plist_del() now has only one
argument, and I think this is good.

I don't mind doing s/plist_next_entry/plist_entry/ if you wish,
but I think this is consistent with plist_next/plist_prev helpers.

And original plist_empty() is confusing. When used on plist's head
it is ok, but it is wrong to use plist_empty(&plist_node).

> Your stuff looks nothing like list.h ..

Is it bad?

Yes, plist_empty/plist_unhashed mimics hlist_empty/hlist_unhashed.

Oleg.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/