[patch 1/1] list_for_each_entry: fs-dquot.c

From: domen
Date: Tue Jun 21 2005 - 01:03:05 EST


From: Domen Puncer <domen@xxxxxxxxxxxx>



Make code more readable with list_for_each_entry_safe.

Signed-off-by: Domen Puncer <domen@xxxxxxxxxxxx>
Signed-off-by: Maximilian Attems <janitor@xxxxxxxxxxxxxx>
Signed-off-by: Domen Puncer <domen@xxxxxxxxxxxx>
---
dquot.c | 7 ++-----
1 files changed, 2 insertions(+), 5 deletions(-)

Index: quilt/fs/dquot.c
===================================================================
--- quilt.orig/fs/dquot.c
+++ quilt/fs/dquot.c
@@ -409,13 +409,10 @@ out_dqlock:
* for this sb+type at all. */
static void invalidate_dquots(struct super_block *sb, int type)
{
- struct dquot *dquot;
- struct list_head *head;
+ struct dquot *dquot, *tmp;

spin_lock(&dq_list_lock);
- for (head = inuse_list.next; head != &inuse_list;) {
- dquot = list_entry(head, struct dquot, dq_inuse);
- head = head->next;
+ list_for_each_entry_safe(dquot, tmp, &inuse_list, dq_inuse) {
if (dquot->dq_sb != sb)
continue;
if (dquot->dq_type != type)

--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/