[patch 04/16] fs/namespace.c: list_for_each_entry

From: domen
Date: Mon Aug 08 2005 - 17:31:57 EST


From: Domen Puncer <domen@xxxxxxxxxxxx>



Make code more readable with list_for_each_entry.

Signed-off-by: Domen Puncer <domen@xxxxxxxxxxxx>
Signed-off-by: Maximilian Attems <janitor@xxxxxxxxxxxxxx>
Signed-off-by: Domen Puncer <domen@xxxxxxxxxxxx>
---
namespace.c | 4 +---
1 files changed, 1 insertion(+), 3 deletions(-)

Index: quilt/fs/namespace.c
===================================================================
--- quilt.orig/fs/namespace.c
+++ quilt/fs/namespace.c
@@ -537,7 +537,6 @@ lives_below_in_same_fs(struct dentry *d,
static struct vfsmount *copy_tree(struct vfsmount *mnt, struct dentry *dentry)
{
struct vfsmount *res, *p, *q, *r, *s;
- struct list_head *h;
struct nameidata nd;

res = q = clone_mnt(mnt, dentry);
@@ -546,8 +545,7 @@ static struct vfsmount *copy_tree(struct
q->mnt_mountpoint = mnt->mnt_mountpoint;

p = mnt;
- for (h = mnt->mnt_mounts.next; h != &mnt->mnt_mounts; h = h->next) {
- r = list_entry(h, struct vfsmount, mnt_child);
+ list_for_each_entry(r, &mnt->mnt_mounts, mnt_child) {
if (!lives_below_in_same_fs(r->mnt_mountpoint, dentry))
continue;


--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/