Re: [patch 1/1] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR

From: Keith Owens
Date: Mon Aug 08 2005 - 18:15:35 EST


On Mon, 8 Aug 2005 21:28:50 +0200,
Andi Kleen <ak@xxxxxxx> wrote:
>On Mon, Aug 08, 2005 at 12:27:10PM -0700, Tom Rini wrote:
>> {
>> unsigned int icr = APIC_DM_FIXED | shortcut | vector | dest;
>> - if (vector == KDB_VECTOR)
>> + if (vector == NMI_VECTOR)
>> icr = (icr & (~APIC_VECTOR_MASK)) | APIC_DM_NMI;
>
>That if () should be removed since it's useless.
>Can you do that please?

Why is 'if ()' useless? Remove the if test and all ipis get sent as
NMI, we definitely do not want that.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/