Re: [PATCH 2.6.13-rc6 1/2] New Syscall: get rlimits of any process

From: Wieland Gmeiner
Date: Tue Aug 16 2005 - 12:37:10 EST


On Sat, 2005-08-13 at 15:11 -0700, Greg KH wrote:
> On Fri, Aug 12, 2005 at 07:48:22PM +0200, Wieland Gmeiner wrote:
> > @@ -294,3 +294,4 @@ ENTRY(sys_call_table)
> > .long sys_inotify_init
> > .long sys_inotify_add_watch
> > .long sys_inotify_rm_watch
> > + .long sys_getprlimit
>
> Please follow the proper kernel coding style when writing new kernel
> code...

Hm, Documentation/CodingStyle suggests using descriptive names, so
something like getrlimit(...)/getrlimit_per_process(pid_t pid, ...)
would be more appropriate?

I thought getrlimit(...)/getprlimit(pid_t pid, ...) would be a good
choice as getgid(void)/getpgid(pid_t pid) already exists in Linux which
have the same naming scheme.

Or would something like
getrlimit/getrlimitpid (like wait(void)/waitpid(pid)) or
getrlimit/getrlimit2 (like getpgrp(void)/getpgrp2(pid) in HP-UX)
be preferred?

What would you suggest?

Thanks,
Wieland

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/